Jump to content
Sign in to follow this  
Nydhruva B

Cannot Launch Game

Recommended Posts

Hello! You may check out our Wiki (specifically the Frequently Asked Questions) for more information.

 

For your problem specifically, you can try the following:

"This error is usually caused by missing or outdated drivers, or misconfigured graphics settings. The first thing to try is run opensetup.exe as an administrator and ensure that the Graphics Device and Resolution settings have both been set. To run Open Setup as admin, right click it and select 'Run as administrator," or you can make this change permanent by right clicking, selecting Properties, going to the Compatibility tab and enabling 'Run this program as an administrator.'

If both these settings are blank and have no available options, try downloading and installing the DirectX Runtime files from Microsoft, as well as updating your graphics card drivers, then run Open Setup again and check if options are now available.

In some cases, you may also be able to fix this error by opening the AnomalyRO Settings app and enable "Override Window Settings." Once you've enabled this setting, just set the desired height and width and you should be able to run the client. This overrides the standard client settings and sometimes allows the client to run normally. You can also enable borderless or full screen mode instead, which will also have the same effect.

 

3rd party solution: If the above solutions don't work, some players have fixed this problem by using DirectX Control Panel. Run dxcpl_x86.exe, go to the 'Direct Draw' tab, and enable 'use hardware acceleration.' After doing this, run Open Setup again and check if the settings are now available. Please note that as this is 3rd party software, we do not provide support for this solution, and cannot take responsibility for any changes the software makes. We've only included it because other players have reported success with this method when other solutions have failed."

 

Let me know if you still encounter problems after this c:

Share this post


Link to post
Share on other sites

Hello,

 

I see that both settings are set in the setup menu. I've used NVIDIA GeForce RTX2070 Direct 3D HAL for Graphics device and set my resolution to 2560x1440x32. Despite this it doesnt work. I've run the app as admin and ensured these changes have taken effect. I've also installed the DirectX runtime files from Microsoft and it still doesn't work. Please advise on next steps.

Share this post


Link to post
Share on other sites

Hi! Sorry for the delay - can you try setting the resolution to 1920x1080 or smaller? The RO client actually has a limit to the resolution it can render at - if setting it to a smaller one works then I'll need to look into it a bit further and see if it's possible to remove that limit from the client, but unfortunately I can't provide an ETA on this yet as I'm not entirely sure how the limit is applied. Playing on a smaller window size should hopefully act as a workaround for now though.

 

Opening the AnomalyRO Settings app (or clicking Settings in the patcher) and changing the Display Mode to Borderless or Full Screen may fix the issue as well while allowing a larger resolution, though I'm not 100% sure if it'll work for you (it does seem to work when running my monitor at 1440p, though it doesn't natively support that resolution so I'm not sure if it might act differently on other monitors).

Share this post


Link to post
Share on other sites

Hey guys .. I'm having the same issue trying from my laptop to play in full screen, or something big enough to be able to play... any other suggestion? I tried everything on this post...

Share this post


Link to post
Share on other sites

Hi Rigonna89, try to change the settings to run the game at windowed mode with resolution of 1920x1080 or smaller. It seems RO does not cannot launch a higher resolution.

Share this post


Link to post
Share on other sites

Hi there,

I did... but its impossible to play on that ridiculous small screen on my laptop.... I even try to lunch full screen with 800x600 and nada....

Share this post


Link to post
Share on other sites

Try using the settings button in the AnomalyRO patcher. I've noticed this opens a different settings menu than the opensetup.exe located in the anomalyRO folder. This worked fine for me.

Should this not work, try the reverse. Open the opensetup.exe in your anomalyRO folder and select your resolution there. Ofcourse the above mentioned resolution limitations will still apply regardless.

Share this post


Link to post
Share on other sites

Just to clarify, the AnomalyRO Settings app also uses OpenSetup (it opens it when you click Graphics Settings). The resolution override in our custom settings app is for specific cases where OpenSetup doesn't properly set the resolution / doesn't list the resolution you want.

 

@Rigonna89, you mentioned trying to run full screen at a lower resolution; unfortunately, this isn't actually possible - when full screen (or borderless mode) is enabled, it'll automatically set it to your screen resolution. The resolution settings currently only work for windowed mode. Right now the only way to play on a higher resolution screen is using windowed mode at up to 1920x1080. I did try looking for a way to override this in the past but I wasn't able to find a solution that actually worked; it seems pretty hardcoded in the client.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×