Jump to content
Mynuo

FAQ Solution hasn't worked for me/ F keys issue

Recommended Posts

Hi! I get the error message "Cannot init d3d OR grf file has problem". I found the FAQ solution but it didn't work: I tried all of the 4 options of graphic devices available, the different resolutions and toggled full-screen mode on and off )': I ran the game the day before yesterday!

 

Also, how can I use the F keys as shortcuts in-game? When I press them, my laptop just does the usual things (My F2 lowers the volume, F3 raises it, etc.)

 

*I reinstalled but the window size is way too small, I switch to full-screen and the error returns.

Edited by Mynuo
update

Share this post


Link to post
Share on other sites

Hello there!

 

Cannot init d3d OR grf file has problem

Have you tried the other options?

  1. Open dinput.ini (in your AnomalyRO folder) in a text editor and setting WindowWidth and WindowHeight to your desired resolutions, or
  2. Installing DirectX Control Panel, Run dxcpl_x86.exe, go to the 'Direct Draw' tab, and enable 'use hardware acceleration'. Then run opensetup,exe again.

 

Enabling F keys shortcuts in-game

  1. Click ESC in-game to open the Game Setting Window
  2. Click 'BM/Shortcut Settings'
    image.png.2ab62c398bc99ffddf61471b7c918ddd.png
  3. Double check if your hotkeys are set up in this way (refer screenshot below)
    image.png.c8232713591dc9286b3ca36e7012fad6.png
  4. If the hotkeys are the same, did you have Adobe Photoshop open? If yes, you need to close it - I have no idea why this happens but yeah.

Share this post


Link to post
Share on other sites

Ok so I kinda fixed it?

 

Instead of dinput.ini (Itried modifying it there but it told me I didn't have permission), I modified the window height and width on AnomalyRO Settings. Now the issue is that all the font looks too small. Oh, and the DirectX thing didn't work either. 

 

Regarding the F keys, I tried setting them there but it just changes the hotkey to "Specified value" and the F keys keep doing their own thing. (Thanks for answering!)

 

Edited by Mynuo

Share this post


Link to post
Share on other sites

YES! At least something good is happening haha. Oh, the lack of permission can be solved by Right-clicking on the file -> "Run as Administrator".

 

Font Size

From your screenshots, I think the font size is the default one :o

But you could try an alternative method that worked on another player.

 

Enabling F keys shortcuts in-game

I believe Sakuretsu has mentioned to you about locking your FN keys? Have you tried that? :o

You can try Google "How to lock FN on XX laptop" as even my laptop doesn't have the FnLk on my keyboard.

Share this post


Link to post
Share on other sites

I did try running dinput as administrator ):

 

Oh no, the font was totally tiny! (I know because the day before yesterday it was fine) But Thanks!!! that alternative method worked :,D

 

Ok so I failed as a 2018 human being, hadn't Googled the FnLk haha. For now, I think I can use the Fs by pressing Fn always before the Fkey :s The Fn Lock method I found didn't work (Pressing Fn + Esc).

Edited by Mynuo

Share this post


Link to post
Share on other sites

Depending on your laptop model you might need to actually change the Function Lock (FnLk) setting in the BIOS. Unfortunately it's hard to give specific instructions since every laptop is a bit different in this regard, but you might be able to find more info if you search for the exact laptop model.

 

As a general outline though, you can usually get to the BIOS by tapping a key during startup (I think it's usually F2 or F10; you might need to temporarily disable fast startup first). Once you're there you'd be looking for something like a "Function Key Behavior" setting, which would have two options - toggling it to the other option would enable Function Lock by default. :o

 

There's some more info on Function Lock settings here.

 

 

Also, you actually did the correct thing in using the AnomalyRO Settings app, the dinput.ini solution on the wiki was actually outdated as I forgot to update the page when we added the settings app. I've updated the FAQ page to reflect that now. :D

Share this post


Link to post
Share on other sites

Thank you so much! 

 

I did read about the BIOS, but as I was using my sister's laptop I decided to wait until I had my own again (I have it now :,3), so hopefully mine won't give me problems with that :3

 

I'm glad at least my problems may help others in the future haha ;D

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×